Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
Eat my SOUP

SMART.scar Error

Recommended Posts

Alright so I still cannot fix this problem, all of the Graphical settings are correct(Safe mode, Highest Brightness setting, Fixed mode) All OSI's are downloaded and updated. I'm going to continue to try and look for more results to possibly fix this, but i cannot find a single answer or any help on this. Here is the Screenshot on the error. If ANYONE can be of assistance i would appreciate it.SMART.Scar--ERROR.png

Share this post


Link to post
Share on other sites

That's odd I can confirm SMART and SmartGetColor (that line in smart.scar) are both currently working.

 

I can't see if you have SMART open by that picture... Have you tried loading runescape in your normal browser closing then trying SMART yet?

 

Please tell us more about your OS, computer, etc.

Share this post


Link to post
Share on other sites

Yea 'wanted', this is actually the same error i have been having for over a week now, I have opened Runescape in my Browsers, opened and set the configuration settings to safemode, highest brightness, and fixed screen. I also did it in my client, I have windows 7, 64 bit, using scar 3.3, and i also had the Smart.scar file open in the picture, it WILL NOT open smart at all, the debug gives me this:

OSI RS2 routines enabled

OSI RS2 color random detection and solving enabled

Loaded RS2 Fonts: OptionChars, ScreenChars, NPCChars, UpChars, SmallChars, StatChars, FriendChars, LoginChars, XPChars

Initating SMART Runescape Server 11 with safe mode enabled...

Runtime error (3931 ms)

After that i just get the message with the SMART.scar error

Share this post


Link to post
Share on other sites
Ok, 'Wanted', so I went to Java, Updated it, And now.... [ATTACH=CONFIG]278[/ATTACH]

 

Try the browser fix again?

Share this post


Link to post
Share on other sites

{$DEFINE RS2}
{$DEFINE SMART} // Comment out to disable SMART

{$I OSI\OSI.scar}

procedure ScriptTerminate;
begin
FreeOSI;
end;

begin
Smart_Server := 1;
SetUpOSI;
end.[/CODe]

 

try playing with Smart_Server maybe?

Share this post


Link to post
Share on other sites

Yea, Played with the Smart_Server and did # 1-11 and still gives me the same Error. Did Find something a bit different from what u posted to what is in the script, the {$I OSI\OSI.scar} is not in the script, and when i use it in the Script in the location you have it in, i get an error in the Globals.Scar. Removed it and back to the errors.

Share this post


Link to post
Share on other sites

Yea, i have all older versions of Java Uninstalled, OSI is up to date, Scar is up to date, the script as far as i know is up to date, and i still get this error. I Cleared my Java Cache,. Re ran everything in my browsers and in my RS client, and still nothing. This error continues to come up. Its just frustrating when I have been Having this problem and it seems nobody knows what it is, or has been having it either,Thanks for the help. Going to keep working at getting it running, but my limited knowledge of this prevents that really.

Share this post


Link to post
Share on other sites

Thanks Freddy, But now that i have this installed, i cannot even get past opening a VM. Mainly, i get an error message saying that i need my VT to be enabled, and with my processor, its not possible, and, i have no idea how to even begin to get smart to open with this.

Share this post


Link to post
Share on other sites
Thanks Freddy, But now that i have this installed, i cannot even get past opening a VM. Mainly, i get an error message saying that i need my VT to be enabled, and with my processor, its not possible, and, i have no idea how to even begin to get smart to open with this.

 

Most modern motherboards should have an option in the bios to enable hardware support for virtualization.

Share this post


Link to post
Share on other sites

I opened my BIOS VT is enabled but is not "working" although after i enabled it in my BIOS I no longer get a message saying " You need to have VT enabled through your BIOS" and just gives me the sentence stating "ERROR: No Bootable Medium Found!" not to sure where to go from here. How would i go about Opening SMART with Virtual Box if i can manage to get this to work?

Share this post


Link to post
Share on other sites

Yes, I have created a OS in the Virtual Machine, That's where i get the original "VT needs to be enabled" and where i now get the "FATAL: No Bootable Medium Found!" message, but since i have not gotten the "VT needs to be enabled" and my i have made sure that my VT is enabled through my BIOS. I'm assuming that it will now work, but with this "FATAL" message i'm not to sure. But yes, i have a OS created.

Share this post


Link to post
Share on other sites

AFAIK you need 32-bit of everything: 32-bit java, scar(i think its only 32 bit), libsmart.dll(the 32bit version that comes with OSI). You then have to make sure that the 32-bit java is selected to run as the VM instead of the 64-bit java(which seems to be your problem).

Share this post


Link to post
Share on other sites

ok, im either completely confused or just plain not in this league of information. So how do i RUN Scar/SMART in the VM? Do i need to have an ISO? all i want to be able to use is smart, or something along to line to let me be able to run a script in a separate window while using my own mouse to not conflict with it.

Share this post


Link to post
Share on other sites
ok, im either completely confused or just plain not in this league of information. So how do i RUN Scar/SMART in the VM? Do i need to have an ISO? all i want to be able to use is smart, or something along to line to let me be able to run a script in a separate window while using my own mouse to not conflict with it.

 

The VM is just like your computer, do what you normally would do(download scar, open includes manager and update OSI, dl a script and run it).

SMART lets you use your mouse while still botting, thats why it was made. Anyway, did you try what i said?(have 32bit of everything and then try running SMART)

Share this post


Link to post
Share on other sites

Yes, i tried that, and i have been running 32 bit everything since the beginning (something i was not aware of until i went to do what you suggested) if i can get smart to work then there will be no need for a VM, correct? But if i cant even get SMART to open, i have returned to original problem that is "Error starting SMART,Ensure the target has an applet deceleration." then the VM wouldn't do anything because of the simple fact that i cant run a script containing them? Im thinking that the possible problem could be my java that i have downloaded? I can say that i HAVE has smart run before, but that was before i had a Hard drive malfunction and had to have that replaced, so weather or not i managed to get all files that i wished to have again back on and downloaded is another matter. Do i JUST need java? Could i possibly need a JDK? I do not believe i had re-installed any of the JDK's i used to have. It just seems to all stem from me now not being able to Open SMART. And it seems that what i am getting is not normal lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...